aboutsummaryrefslogtreecommitdiff
path: root/rand/rand_jitter/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rand/rand_jitter/Cargo.toml')
-rw-r--r--rand/rand_jitter/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/rand/rand_jitter/Cargo.toml b/rand/rand_jitter/Cargo.toml
new file mode 100644
index 0000000..5b7e3c3
--- /dev/null
+++ b/rand/rand_jitter/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "rand_jitter"
+version = "0.2.1"
+authors = ["The Rand Project Developers"]
+license = "MIT OR Apache-2.0"
+readme = "README.md"
+repository = "https://github.com/rust-random/rand"
+documentation = "https://docs.rs/rand_jitter"
+description = "Random number generator based on timing jitter"
+keywords = ["random", "rng", "os"]
+edition = "2018"
+
+[badges]
+travis-ci = { repository = "rust-random/rand" }
+appveyor = { repository = "rust-random/rand" }
+
+[dependencies]
+rand_core = { path = "../rand_core", version = "0.5" }
+log = { version = "0.4", optional = true }
+
+[target.'cfg(any(target_os = "macos", target_os = "ios"))'.dependencies]
+# We don't need the 'use_std' feature and depending on it causes
+# issues due to: https://github.com/rust-lang/cargo/issues/1197
+libc = { version = "0.2", default_features = false }
+
+[target.'cfg(target_os = "windows")'.dependencies]
+winapi = { version = "0.3", features = ["profileapi"] }
+
+[features]
+std = ["rand_core/std"]