aboutsummaryrefslogtreecommitdiff
path: root/rand/rand_jitter/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2020-01-02 08:32:06 -0800
committerDaniel Mueller <deso@posteo.net>2020-01-02 08:32:06 -0800
commitfd091b04316db9dc5fafadbd6bdbe60b127408a9 (patch)
treef202270f7ae5cedc513be03833a26148d9b5e219 /rand/rand_jitter/Cargo.toml
parent8161cdb26f98e65b39c603ddf7a614cc87c77a1c (diff)
downloadnitrocli-fd091b04316db9dc5fafadbd6bdbe60b127408a9.tar.gz
nitrocli-fd091b04316db9dc5fafadbd6bdbe60b127408a9.tar.bz2
Update nitrokey crate to 0.4.0
This change finally updates the version of the nitrokey crate that we consume to 0.4.0. Along with that we update rand_core, one of its dependencies, to 0.5.1. Further more we add cfg-if in version 0.1.10 and getrandom in version 0.1.13, both of which are now new (non-development) dependencies. Import subrepo nitrokey/:nitrokey at e81057037e9b4f370b64c0a030a725bc6bdfb870 Import subrepo cfg-if/:cfg-if at 4484a6faf816ff8058088ad857b0c6bb2f4b02b2 Import subrepo getrandom/:getrandom at d661aa7e1b8cc80b47dabe3d2135b3b47d2858af Import subrepo rand/:rand at d877ed528248b52d947e0484364a4e1ae59ca502
Diffstat (limited to 'rand/rand_jitter/Cargo.toml')
-rw-r--r--rand/rand_jitter/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/rand/rand_jitter/Cargo.toml b/rand/rand_jitter/Cargo.toml
new file mode 100644
index 0000000..5b7e3c3
--- /dev/null
+++ b/rand/rand_jitter/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "rand_jitter"
+version = "0.2.1"
+authors = ["The Rand Project Developers"]
+license = "MIT OR Apache-2.0"
+readme = "README.md"
+repository = "https://github.com/rust-random/rand"
+documentation = "https://docs.rs/rand_jitter"
+description = "Random number generator based on timing jitter"
+keywords = ["random", "rng", "os"]
+edition = "2018"
+
+[badges]
+travis-ci = { repository = "rust-random/rand" }
+appveyor = { repository = "rust-random/rand" }
+
+[dependencies]
+rand_core = { path = "../rand_core", version = "0.5" }
+log = { version = "0.4", optional = true }
+
+[target.'cfg(any(target_os = "macos", target_os = "ios"))'.dependencies]
+# We don't need the 'use_std' feature and depending on it causes
+# issues due to: https://github.com/rust-lang/cargo/issues/1197
+libc = { version = "0.2", default_features = false }
+
+[target.'cfg(target_os = "windows")'.dependencies]
+winapi = { version = "0.3", features = ["profileapi"] }
+
+[features]
+std = ["rand_core/std"]