aboutsummaryrefslogtreecommitdiff
path: root/hidapi-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2017-03-26 17:07:48 -0700
committerDaniel Mueller <deso@posteo.net>2017-03-26 17:07:48 -0700
commit654b2e5fa1566f0479b09adf2d73f783196ad032 (patch)
treee7805428a5db957d94e414deaa66b6555a0f6003 /hidapi-sys/Cargo.toml
parentcb39828ecd7ea5d2eac3076ad3dd1b6ef05e10d3 (diff)
downloadnitrocli-654b2e5fa1566f0479b09adf2d73f783196ad032.tar.gz
nitrocli-654b2e5fa1566f0479b09adf2d73f783196ad032.tar.bz2
Import subrepo hidapi-sys/:hidapi-sys at ec441b2751dcbbcd053800b6901672c999651584
Diffstat (limited to 'hidapi-sys/Cargo.toml')
-rw-r--r--hidapi-sys/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/hidapi-sys/Cargo.toml b/hidapi-sys/Cargo.toml
new file mode 100644
index 0000000..15b4e9e
--- /dev/null
+++ b/hidapi-sys/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "hidapi-sys"
+version = "0.1.2"
+build = "build.rs"
+links = "hidapi"
+
+authors = ["meh. <meh@schizofreni.co>"]
+license = "WTFPL"
+
+description = "FFI bindings to hidapi"
+repository = "https://github.com/meh/rust-hidapi-sys"
+keywords = ["hid"]
+categories = ["external-ffi-bindings", "hardware-support", "os"]
+
+[features]
+static = []
+build = ["static"]
+
+[dependencies]
+libc = "0.2"
+
+[build-dependencies]
+gcc = "0.3"
+pkg-config = "0.3"