aboutsummaryrefslogtreecommitdiff
path: root/cc/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2018-01-15 09:36:38 -0800
committerDaniel Mueller <deso@posteo.net>2018-01-15 09:36:38 -0800
commitf3149d7f2802711791c490b71313aafc55f4809c (patch)
treecd0247b0d856be8b9e010738646965233aa60c93 /cc/Cargo.toml
parentd8a58488bd56ef9c09e167173124c3519bc7405d (diff)
downloadnitrocli-f3149d7f2802711791c490b71313aafc55f4809c.tar.gz
nitrocli-f3149d7f2802711791c490b71313aafc55f4809c.tar.bz2
Update hidapi-sys crate to 0.1.4
This change updates the hidapi-sys crate to version 0.1.4. In this version the cc crate (the stable and renamed version of the gcc crate) is used. Import subrepo hidapi-sys/:hidapi-sys at c01043da72c0cac898660017e4c4115278c14369 Import subrepo cc/:cc at 500c65b03775cecf55bd358e616963bc3222acca
Diffstat (limited to 'cc/Cargo.toml')
-rw-r--r--cc/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/cc/Cargo.toml b/cc/Cargo.toml
new file mode 100644
index 0000000..cd87a6f
--- /dev/null
+++ b/cc/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+
+name = "cc"
+version = "1.0.4"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/alexcrichton/cc-rs"
+homepage = "https://github.com/alexcrichton/cc-rs"
+documentation = "https://docs.rs/cc"
+description = """
+A build-time dependency for Cargo build scripts to assist in invoking the native
+C compiler to compile native C code into a static archive to be linked into Rust
+code.
+"""
+keywords = ["build-dependencies"]
+readme = "README.md"
+categories = ["development-tools"]
+
+[badges]
+travis-ci = { repository = "alexcrichton/cc-rs" }
+appveyor = { repository = "alexcrichton/cc-rs" }
+
+[dependencies]
+rayon = { version = "0.9", optional = true }
+
+[features]
+parallel = ["rayon"]
+
+[dev-dependencies]
+tempdir = "0.3"