aboutsummaryrefslogtreecommitdiff
path: root/base32/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-01-06 00:20:04 +0100
committerDaniel Mueller <deso@posteo.net>2019-01-13 18:37:08 -0800
commitcb5b22d0886a0a8c19cf1afeef55a8245357cf20 (patch)
treecfcc555186317bac4f4383a9380e0d6ef6d58459 /base32/Cargo.toml
parent38e7e1d92ce4aea7840d78bcda6246bd61c423ac (diff)
downloadnitrocli-cb5b22d0886a0a8c19cf1afeef55a8245357cf20.tar.gz
nitrocli-cb5b22d0886a0a8c19cf1afeef55a8245357cf20.tar.bz2
Add the base32 crate in version 0.4.0 as a dependency
To parse OTP secrets in base32 representation, we need a new dependency: the base32 crate. Import subrepo base32/:base32 at a74cd9246fc0e08d6f5cfcb644bfdf76dd438613
Diffstat (limited to 'base32/Cargo.toml')
-rw-r--r--base32/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/base32/Cargo.toml b/base32/Cargo.toml
new file mode 100644
index 0000000..ff63bbe
--- /dev/null
+++ b/base32/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+
+name = "base32"
+version = "0.4.0"
+authors = [ "Andreas Ots <qrpth@qrpth.eu>", "Tim Dumol <tim@timdumol.com>" ]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/andreasots/base32"
+description = "Base32 encoder/decoder for Rust"
+
+[lib]
+
+name = "base32"
+
+[dev-dependencies]
+quickcheck = "0.7.1"
+rand = "0.5.5"