aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2020-04-04 15:13:33 -0700
committerDaniel Mueller <deso@posteo.net>2020-04-04 15:13:33 -0700
commit31fffa2fe2ad77215be285ab963d0c3565b32ff2 (patch)
treea74023f7616e61d432f745f68a07a7861b720256 /Cargo.toml
parent681cc8882f7995407c33eb48730daaa901074460 (diff)
downloadnitrocli-31fffa2fe2ad77215be285ab963d0c3565b32ff2.tar.gz
nitrocli-31fffa2fe2ad77215be285ab963d0c3565b32ff2.tar.bz2
Add structopt dependency in version 0.3.7
This patch series replaces argparse with structopt in the argument handling code. As a first step, we need structopt as a dependency.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 63e6409..cbb735f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -54,6 +54,10 @@ version = "0.2"
[dependencies.nitrokey]
version = "0.4.0"
+[dependencies.structopt]
+version = "0.3.7"
+default-features = false
+
[dev-dependencies.nitrokey-test]
version = "0.3.1"