aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2020-04-04 15:32:14 -0700
committerDaniel Mueller <deso@posteo.net>2020-04-04 15:32:14 -0700
commit681cc8882f7995407c33eb48730daaa901074460 (patch)
treec865f6c4a34e11af685889a09d95f3225e54a16c /Cargo.toml
parentd0d9683df8398696147e7ee1fcffb2e4e957008c (diff)
downloadnitrocli-681cc8882f7995407c33eb48730daaa901074460.tar.gz
nitrocli-681cc8882f7995407c33eb48730daaa901074460.tar.bz2
Move nitrocli source code into repository root
Now that all vendored dependencies have been removed, this change moves the program's source code from the nitrocli/ directory into the root of the repository.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml64
1 files changed, 64 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..63e6409
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,64 @@
+# Cargo.toml
+
+#/***************************************************************************
+# * Copyright (C) 2017-2020 Daniel Mueller (deso@posteo.net) *
+# * *
+# * This program is free software: you can redistribute it and/or modify *
+# * it under the terms of the GNU General Public License as published by *
+# * the Free Software Foundation, either version 3 of the License, or *
+# * (at your option) any later version. *
+# * *
+# * This program is distributed in the hope that it will be useful, *
+# * but WITHOUT ANY WARRANTY; without even the implied warranty of *
+# * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the *
+# * GNU General Public License for more details. *
+# * *
+# * You should have received a copy of the GNU General Public License *
+# * along with this program. If not, see <http://www.gnu.org/licenses/>. *
+# ***************************************************************************/
+
+[package]
+name = "nitrocli"
+version = "0.3.1"
+edition = "2018"
+authors = ["Daniel Mueller <deso@posteo.net>"]
+license = "GPL-3.0-or-later"
+homepage = "https://github.com/d-e-s-o/nitrocli"
+repository = "https://github.com/d-e-s-o/nitrocli.git"
+readme = "README.md"
+categories = ["command-line-utilities", "authentication", "cryptography", "hardware-support"]
+keywords = ["nitrokey", "nitrokey-storage", "nitrokey-pro", "cli", "usb"]
+description = """
+A command line tool for interacting with Nitrokey devices.
+"""
+exclude = ["ci/*", "rustfmt.toml"]
+
+[badges]
+gitlab = { repository = "d-e-s-o/nitrocli", branch = "master" }
+
+[profile.release]
+opt-level = "z"
+lto = true
+codegen-units = 1
+incremental = false
+
+[dependencies.argparse]
+version = "0.2.2"
+
+[dependencies.base32]
+version = "0.4.0"
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.nitrokey]
+version = "0.4.0"
+
+[dev-dependencies.nitrokey-test]
+version = "0.3.1"
+
+[dev-dependencies.nitrokey-test-state]
+version = "0.1"
+
+[dev-dependencies.regex]
+version = "1"