aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-02-18 22:24:25 +0000
committerRobin Krahl <robin.krahl@ireas.org>2019-02-18 23:27:55 +0100
commitf80cef80cf685066fb50385e14568bf86e700d88 (patch)
treecde3257cd697af0e49b36182ae2545a3c9a83182 /Cargo.toml
parent9df0f3bd565dfbf8c97d02969a17504c688bf381 (diff)
downloadntw-f80cef80cf685066fb50385e14568bf86e700d88.tar.gz
ntw-f80cef80cf685066fb50385e14568bf86e700d88.tar.bz2
Use ssmarshal to convert data from and to byte slices
Previously, we manually converted the request and response data from and to byte slices. This patch adds the ssmarshal dependency that automates the serialization and deserialization in the required format.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e3614d5..a11296e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -22,6 +22,15 @@ package = "stm32f1xx-hal"
version = "0.1.1"
features = ["stm32f103", "rt"]
+[dependencies.serde]
+version = "1.0"
+default-features = false
+features = ["derive"]
+
+[dependencies.ssmarshal]
+version = "1.0"
+default-features = false
+
[profile.release]
codegen-units = 1
debug = true