aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-02-18 10:56:30 +0000
committerRobin Krahl <robin.krahl@ireas.org>2019-02-18 15:30:10 +0100
commit7da90438dd7851f66abfa81eba2eeb36ff9c9c25 (patch)
tree400bd0f6ab5e15899bd3fc1d8df55b57acfd1cf8 /Cargo.toml
parenta3f0fb062048c52c3f04e907f0107e1db9b6141c (diff)
downloadntw-7da90438dd7851f66abfa81eba2eeb36ff9c9c25.tar.gz
ntw-7da90438dd7851f66abfa81eba2eeb36ff9c9c25.tar.bz2
Add USB stack and simple HID implementation
This patch adds the usb-device and stm32f103xx-usb crates that provide a USB stack. It introduces the HidClass struct, a basic implementation of the Human Interface Device (HID) USB class. Devices with that class are recognized as HID devices with the specified vendor and product ID, but do not provide the endpoints required for interaction.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index aa96ab0..e3614d5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,6 +14,8 @@ cortex-m = "0.5.8"
cortex-m-rt = "0.6.7"
embedded-hal = "0.2.2"
panic-halt = "0.2.0"
+stm32f103xx-usb = { git = "https://github.com/mvirkkunen/stm32f103xx-usb", rev = "57d23751367461bec5f39322727bdd65e5c2aa30" }
+usb-device = { git = "https://github.com/mvirkkunen/usb-device", rev = "e58e30f3b9c9bf4aab00ea039d129b964a3fd2d3" }
[dependencies.hal]
package = "stm32f1xx-hal"