aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-02-01 01:03:25 +0100
committerRobin Krahl <robin.krahl@ireas.org>2019-02-18 15:29:56 +0100
commita3f0fb062048c52c3f04e907f0107e1db9b6141c (patch)
tree07531f53a38f8b5440f3f48c6ff21e945cb506c9 /Cargo.toml
downloadntw-a3f0fb062048c52c3f04e907f0107e1db9b6141c.tar.gz
ntw-a3f0fb062048c52c3f04e907f0107e1db9b6141c.tar.bz2
Initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..aa96ab0
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,26 @@
+# Copyright 2019 Robin Krahl <robin.krahl@ireas.org>
+# SPDX-License-Identifier: CC0-1.0
+
+[package]
+name = "ntw"
+version = "0.1.0"
+authors = ["Robin Krahl <robin.krahl@ireas.org>"]
+description = "experimental firmware for the Nitrokey Pro"
+readme = "README.md"
+edition = "2018"
+
+[dependencies]
+cortex-m = "0.5.8"
+cortex-m-rt = "0.6.7"
+embedded-hal = "0.2.2"
+panic-halt = "0.2.0"
+
+[dependencies.hal]
+package = "stm32f1xx-hal"
+version = "0.1.1"
+features = ["stm32f103", "rt"]
+
+[profile.release]
+codegen-units = 1
+debug = true
+lto = true