aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-12-17 08:57:16 +0000
committerRobin Krahl <robin.krahl@ireas.org>2019-12-17 10:17:28 +0100
commit1dfd8694c6dfa31ba154456cd17ef2efe6bd7c7a (patch)
tree01e05b540040aa21ca620cbc6479d99b1c462853 /Cargo.toml
parent1ea7b2476d9a5f97ddf43f999306a70d7c5167d3 (diff)
downloadntw-1dfd8694c6dfa31ba154456cd17ef2efe6bd7c7a.tar.gz
ntw-1dfd8694c6dfa31ba154456cd17ef2efe6bd7c7a.tar.bz2
Update dependencies to newest versions
This patch updates all dependencies to the newest versions (except static_assertions). It replaces the Git versions of stm32f103xx-usb and usb-device with crates.io versions of stm32-usbd (via stm32f1xx-hal) and usb-device. This bumps the minimum supported Rust version to 1.36.0 (for stm32-usbd). static_assertions is not updated as it would require an even newer Rust version.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 8 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0d773d8..8504c06 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,19 +10,18 @@ readme = "README.md"
edition = "2018"
[dependencies]
-cortex-m = "0.5.8"
-cortex-m-rt = "0.6.7"
-embedded-hal = "0.2.2"
+cortex-m = "0.6.1"
+cortex-m-rt = "0.6.11"
+embedded-hal = "0.2.3"
panic-halt = "0.2.0"
-serde-big-array = "0.1.4"
-static_assertions = "0.3.1"
-stm32f103xx-usb = { git = "https://github.com/mvirkkunen/stm32f103xx-usb", rev = "57d23751367461bec5f39322727bdd65e5c2aa30" }
-usb-device = { git = "https://github.com/mvirkkunen/usb-device", rev = "e58e30f3b9c9bf4aab00ea039d129b964a3fd2d3" }
+serde-big-array = "0.2.0"
+static_assertions = "0.3.4"
+usb-device = "0.2.3"
[dependencies.hal]
package = "stm32f1xx-hal"
-version = "0.1.1"
-features = ["stm32f103", "rt"]
+version = "0.5.2"
+features = ["stm32-usbd", "stm32f103", "rt"]
[dependencies.serde]
version = "1.0"