aboutsummaryrefslogtreecommitdiff
path: root/rand/rand_xoshiro/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rand/rand_xoshiro/Cargo.toml')
-rw-r--r--rand/rand_xoshiro/Cargo.toml16
1 files changed, 11 insertions, 5 deletions
diff --git a/rand/rand_xoshiro/Cargo.toml b/rand/rand_xoshiro/Cargo.toml
index 8d174c7..128c213 100644
--- a/rand/rand_xoshiro/Cargo.toml
+++ b/rand/rand_xoshiro/Cargo.toml
@@ -1,8 +1,8 @@
[package]
name = "rand_xoshiro"
-version = "0.1.0" # NB: When modifying, also modify html_root_url in lib.rs
+version = "0.3.1" # NB: When modifying, also modify html_root_url in lib.rs
authors = ["The Rand Project Developers"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
readme = "README.md"
repository = "https://github.com/rust-random/rand"
documentation = "https://docs.rs/rand_xoshiro"
@@ -10,10 +10,16 @@ homepage = "https://crates.io/crates/rand_xoshiro"
description = "Xoshiro, xoroshiro and splitmix64 random number generators"
keywords = ["random", "rng"]
categories = ["algorithms"]
+edition = "2018"
+
+[features]
+serde1 = ["serde"]
[dependencies]
-byteorder = { version = "1", default-features=false }
-rand_core = { path = "../rand_core", version = "0.3", default-features=false }
+rand_core = { path = "../rand_core", version = "0.5" }
+serde = { version = "1", features = ["derive"], optional=true }
[dev-dependencies]
-rand = { path = "..", version = "0.6", default-features=false } # needed for doctests
+# This is for testing serde, unfortunately we can't specify feature-gated dev
+# deps yet, see: https://github.com/rust-lang/cargo/issues/1596
+bincode = { version = "1" }