aboutsummaryrefslogtreecommitdiff
path: root/rand/rand_pcg/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rand/rand_pcg/Cargo.toml')
-rw-r--r--rand/rand_pcg/Cargo.toml23
1 files changed, 9 insertions, 14 deletions
diff --git a/rand/rand_pcg/Cargo.toml b/rand/rand_pcg/Cargo.toml
index c2fcb7d..e2aa157 100644
--- a/rand/rand_pcg/Cargo.toml
+++ b/rand/rand_pcg/Cargo.toml
@@ -1,37 +1,32 @@
[package]
name = "rand_pcg"
-version = "0.1.1"
+version = "0.2.0"
authors = ["The Rand Project Developers"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
readme = "README.md"
repository = "https://github.com/rust-random/rand"
-documentation = "https://rust-random.github.io/rand/rand_pcg"
+documentation = "https://rust-random.github.io/rand/rand_pcg/"
homepage = "https://crates.io/crates/rand_pcg"
description = """
Selected PCG random number generators
"""
keywords = ["random", "rng", "pcg"]
categories = ["algorithms", "no-std"]
-build = "build.rs"
+edition = "2018"
[badges]
travis-ci = { repository = "rust-random/rand" }
appveyor = { repository = "rust-random/rand" }
[features]
-serde1 = ["serde", "serde_derive"]
+serde1 = ["serde"]
[dependencies]
-rand_core = { path = "../rand_core", version = "0.3", default-features=false }
-serde = { version = "1", optional = true }
-serde_derive = { version = "^1.0.38", optional = true }
+rand_core = { path = "../rand_core", version = "0.5" }
+serde = { version = "1", features = ["derive"], optional = true }
[dev-dependencies]
# This is for testing serde, unfortunately we can't specify feature-gated dev
# deps yet, see: https://github.com/rust-lang/cargo/issues/1596
-# TODO: we shouldn't have to depend on i128 directly; it breaks tests on old
-# compilers. `bincode` should automatically support this.
-bincode = { version = "1", features = ["i128"] }
-
-[build-dependencies]
-autocfg = "0.1"
+# We require at least 1.1.2 for i128 auto-detection
+bincode = { version = "1.1.2" }