aboutsummaryrefslogtreecommitdiff
path: root/rand/rand_os/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rand/rand_os/Cargo.toml')
-rw-r--r--rand/rand_os/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/rand/rand_os/Cargo.toml b/rand/rand_os/Cargo.toml
new file mode 100644
index 0000000..2f9224a
--- /dev/null
+++ b/rand/rand_os/Cargo.toml
@@ -0,0 +1,38 @@
+[package]
+name = "rand_os"
+version = "0.1.1"
+authors = ["The Rand Project Developers"]
+license = "MIT/Apache-2.0"
+readme = "README.md"
+repository = "https://github.com/rust-random/rand"
+documentation = "https://docs.rs/rand_os"
+homepage = "https://crates.io/crates/rand_os"
+description = "OS backed Random Number Generator"
+keywords = ["random", "rng", "os"]
+
+[badges]
+travis-ci = { repository = "rust-random/rand" }
+appveyor = { repository = "rust-random/rand" }
+
+[dependencies]
+rand_core = { path = "../rand_core", version = "0.3", default-features = false }
+log = { version = "0.4", optional = true }
+
+[target.'cfg(unix)'.dependencies]
+libc = "0.2"
+
+[target.'cfg(windows)'.dependencies]
+winapi = { version = "0.3", features = ["minwindef", "ntsecapi", "winnt"] }
+
+[target.'cfg(target_os = "cloudabi")'.dependencies]
+cloudabi = "0.0.3"
+
+[target.'cfg(target_os = "fuchsia")'.dependencies]
+fuchsia-zircon = "0.3.2"
+
+[target.wasm32-unknown-unknown.dependencies]
+wasm-bindgen = { version = "0.2.12", optional = true }
+stdweb = { version = "0.4", optional = true }
+
+[target.'cfg(target_env = "sgx")'.dependencies]
+rdrand = "0.4.0"