aboutsummaryrefslogtreecommitdiff
path: root/rand/rand_isaac/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rand/rand_isaac/Cargo.toml')
-rw-r--r--rand/rand_isaac/Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/rand/rand_isaac/Cargo.toml b/rand/rand_isaac/Cargo.toml
index b35d0ab..c11c305 100644
--- a/rand/rand_isaac/Cargo.toml
+++ b/rand/rand_isaac/Cargo.toml
@@ -1,29 +1,29 @@
[package]
name = "rand_isaac"
-version = "0.1.1"
+version = "0.2.0"
authors = ["The Rand Project Developers", "The Rust Project Developers"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
readme = "README.md"
repository = "https://github.com/rust-random/rand"
-documentation = "https://rust-random.github.io/rand/rand_isaac"
+documentation = "https://rust-random.github.io/rand/rand_isaac/"
homepage = "https://crates.io/crates/rand_isaac"
description = """
ISAAC random number generator
"""
keywords = ["random", "rng", "isaac"]
categories = ["algorithms", "no-std"]
+edition = "2018"
[badges]
travis-ci = { repository = "rust-random/rand" }
appveyor = { repository = "rust-random/rand" }
[features]
-serde1 = ["serde", "serde_derive", "rand_core/serde1"]
+serde1 = ["serde", "rand_core/serde1"]
[dependencies]
-rand_core = { path = "../rand_core", version = "0.3", default-features=false }
-serde = { version = "1", optional = true }
-serde_derive = { version = "^1.0.38", optional = true }
+rand_core = { path = "../rand_core", version = "0.5" }
+serde = { version = "1", features = ["derive"], optional = true }
[dev-dependencies]
# This is for testing serde, unfortunately we can't specify feature-gated dev