aboutsummaryrefslogtreecommitdiff
path: root/nitrokey/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'nitrokey/Cargo.toml')
-rw-r--r--nitrokey/Cargo.toml13
1 files changed, 6 insertions, 7 deletions
diff --git a/nitrokey/Cargo.toml b/nitrokey/Cargo.toml
index 62eea02..b57591b 100644
--- a/nitrokey/Cargo.toml
+++ b/nitrokey/Cargo.toml
@@ -1,9 +1,9 @@
-# Copyright (C) 2019 Robin Krahl <robin.krahl@ireas.org>
-# SPDX-License-Identifier: MIT
+# Copyright (C) 2019-2020 Robin Krahl <robin.krahl@ireas.org>
+# SPDX-License-Identifier: CC0-1.0
[package]
name = "nitrokey"
-version = "0.4.0-alpha.3"
+version = "0.4.0"
authors = ["Robin Krahl <robin.krahl@ireas.org>"]
edition = "2018"
homepage = "https://code.ireas.org/nitrokey-rs/"
@@ -17,12 +17,11 @@ license = "MIT"
exclude = [".builds/*"]
[dependencies]
-lazy_static = "1.2.0"
+lazy_static = "1.2"
libc = "0.2"
nitrokey-sys = "3.5"
-rand_core = {version = "0.3", default-features = false, features = ["std"] }
-rand_os = {version = "0.1"}
+rand_core = {version = "0.5.1", features = ["getrandom"] }
[dev-dependencies]
nitrokey-test = "0.3"
-nitrokey-test-state = "0.1.0"
+nitrokey-test-state = "0.1"