aboutsummaryrefslogtreecommitdiff
path: root/getrandom/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'getrandom/Cargo.toml')
-rw-r--r--getrandom/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/getrandom/Cargo.toml b/getrandom/Cargo.toml
new file mode 100644
index 0000000..b159674
--- /dev/null
+++ b/getrandom/Cargo.toml
@@ -0,0 +1,45 @@
+[package]
+name = "getrandom"
+version = "0.1.13"
+edition = "2018"
+authors = ["The Rand Project Developers"]
+license = "MIT OR Apache-2.0"
+description = "A small cross-platform library for retrieving random data from system source"
+documentation = "https://docs.rs/getrandom"
+repository = "https://github.com/rust-random/getrandom"
+categories = ["os", "no-std"]
+exclude = ["utils/*", ".*", "appveyor.yml"]
+
+[badges]
+travis-ci = { repository = "rust-random/getrandom" }
+appveyor = { repository = "rust-random/getrandom" }
+
+[dependencies]
+log = { version = "0.4", optional = true }
+cfg-if = "0.1.2"
+
+# When built as part of libstd
+compiler_builtins = { version = "0.1", optional = true }
+core = { version = "1.0", optional = true, package = "rustc-std-workspace-core" }
+
+[target.'cfg(unix)'.dependencies]
+libc = { version = "0.2.64", default-features = false }
+
+[target.'cfg(target_os = "wasi")'.dependencies]
+wasi = "0.7"
+
+[target.wasm32-unknown-unknown.dependencies]
+wasm-bindgen = { version = "0.2.29", optional = true }
+stdweb = { version = "0.4.18", optional = true }
+
+[target.wasm32-unknown-unknown.dev-dependencies]
+wasm-bindgen-test = "0.2"
+
+[features]
+std = []
+# Enables dummy implementation for unsupported targets
+dummy = []
+# Unstable feature to support being a libstd dependency
+rustc-dep-of-std = ["compiler_builtins", "core"]
+# Unstable feature for testing
+test-in-browser = ["wasm-bindgen"]