aboutsummaryrefslogtreecommitdiff
path: root/nitrokey/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2019-08-12 22:07:44 -0700
committerDaniel Mueller <deso@posteo.net>2019-08-12 22:07:44 -0700
commit4dc73375e0364aea70b52682b916635b7b75a2eb (patch)
treeb92b238d61c14bb634db699dedcd714918b84975 /nitrokey/Cargo.toml
parenta18066a1a10792ddbd57527ad58f75fc84fafad2 (diff)
downloadnitrocli-4dc73375e0364aea70b52682b916635b7b75a2eb.tar.gz
nitrocli-4dc73375e0364aea70b52682b916635b7b75a2eb.tar.bz2
Update nitrokey crate to 0.4.0-alpha.2
This change updates the dependency to nitrokey to version 0.4.0-alpha.2. In addition to minor interface changes for the get_*_firmware_version and get_*_retry_count functions, several functions that change the device state now require a mutable handle to the nitrokey. Hence, this patch a number of function signatures to accept mutable device objects. Import subrepo nitrokey/:nitrokey at 34efcfadf1436102e42144f710edabaa2c4b55cd
Diffstat (limited to 'nitrokey/Cargo.toml')
-rw-r--r--nitrokey/Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/nitrokey/Cargo.toml b/nitrokey/Cargo.toml
index 084bcea..fd6fef7 100644
--- a/nitrokey/Cargo.toml
+++ b/nitrokey/Cargo.toml
@@ -3,7 +3,7 @@
[package]
name = "nitrokey"
-version = "0.4.0-alpha.0"
+version = "0.4.0-alpha.2"
authors = ["Robin Krahl <robin.krahl@ireas.org>"]
edition = "2018"
homepage = "https://code.ireas.org/nitrokey-rs/"
@@ -14,12 +14,13 @@ keywords = ["nitrokey", "otp"]
categories = ["api-bindings"]
readme = "README.md"
license = "MIT"
+exclude = [".builds/*"]
[dependencies]
libc = "0.2"
-nitrokey-sys = "3.4"
+nitrokey-sys = "~3.4"
rand_core = {version = "0.3", default-features = false, features = ["std"] }
rand_os = {version = "0.1"}
[dev-dependencies]
-nitrokey-test = {version = "0.2"}
+nitrokey-test = {version = "=0.2.0"}