aboutsummaryrefslogtreecommitdiff
path: root/nitrokey-sys/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <me@robin-krahl.de>2018-12-11 23:50:45 +0100
committerDaniel Mueller <deso@posteo.net>2018-12-17 07:52:13 -0800
commit986ad2f782cf944990e4eda8bf88ea1821233302 (patch)
tree1717075a4eb11861c32e5c45d01e47360fb1264d /nitrokey-sys/Cargo.toml
parente97c287c01cf22a1b582a7da9b309b58f3935d0e (diff)
downloadnitrocli-986ad2f782cf944990e4eda8bf88ea1821233302.tar.gz
nitrocli-986ad2f782cf944990e4eda8bf88ea1821233302.tar.bz2
Add nitrokey as a dependency to nitrocli
The nitrokey crate provides a simple interface to the Nitrokey Storage and the Nitrokey Pro based on the libnitrokey library developed by Nitrokey UG. The low-level bindings to this library are available in the nitrokey-sys crate. This patch adds version v0.2.1 of the nitrokey crate as a dependency for nitrocli. It includes the indirect dependencies nitrokey-sys (version 3.4.1) and rand (version 0.4.3). Import subrepo nitrokey/:nitrokey at 2eccc96ceec2282b868891befe9cda7f941fbe7b Import subrepo nitrokey-sys/:nitrokey-sys at f1a11ebf72610fb9cf80ac7f9f147b4ba1a5336f Import subrepo rand/:rand at d7d5da49daf7ceb3e5940072940d495cced3a1b3
Diffstat (limited to 'nitrokey-sys/Cargo.toml')
-rw-r--r--nitrokey-sys/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/nitrokey-sys/Cargo.toml b/nitrokey-sys/Cargo.toml
new file mode 100644
index 0000000..2486b77
--- /dev/null
+++ b/nitrokey-sys/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "nitrokey-sys"
+version = "3.4.1"
+authors = ["Robin Krahl <robin.krahl@ireas.org>"]
+homepage = "https://code.ireas.org/nitrokey-rs/"
+repository = "https://git.ireas.org/nitrokey-sys-rs/"
+description = "Low-level bindings to libnitrokey for communication with Nitrokey devices"
+categories = ["external-ffi-bindings"]
+license = "LGPL-3.0"
+links = "nitrokey"
+build = "build.rs"
+readme = "README.md"
+
+[build-dependencies]
+cc = "1.0"