aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2017-03-03 21:53:10 -0800
committerDaniel Mueller <deso@posteo.net>2017-03-03 21:53:10 -0800
commit701c71952afc199fc1a9f0d45a7b5fb08cabffe8 (patch)
tree13771f69782537265b5a617e5c80236c2f1700d5 /nitrocli/Cargo.toml
parent542b90f2fb6ef96b6c2cd7234e8800313e95cf34 (diff)
downloadnitrocli-701c71952afc199fc1a9f0d45a7b5fb08cabffe8.tar.gz
nitrocli-701c71952afc199fc1a9f0d45a7b5fb08cabffe8.tar.bz2
Add basic scaffolding
This change adds the basic scaffolding for the nitrocli application. The scaffolding was created using the following command: $ cargo new --bin nitrocli The application aims at providing a command line interface for the Nitrokey Storage device.
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
new file mode 100644
index 0000000..ceaf276
--- /dev/null
+++ b/nitrocli/Cargo.toml
@@ -0,0 +1,31 @@
+# Cargo.toml
+
+#/***************************************************************************
+# * Copyright (C) 2017 Daniel Mueller (deso@posteo.net) *
+# * *
+# * This program is free software: you can redistribute it and/or modify *
+# * it under the terms of the GNU General Public License as published by *
+# * the Free Software Foundation, either version 3 of the License, or *
+# * (at your option) any later version. *
+# * *
+# * This program is distributed in the hope that it will be useful, *
+# * but WITHOUT ANY WARRANTY; without even the implied warranty of *
+# * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the *
+# * GNU General Public License for more details. *
+# * *
+# * You should have received a copy of the GNU General Public License *
+# * along with this program. If not, see <http://www.gnu.org/licenses/>. *
+# ***************************************************************************/
+
+[package]
+name = "nitrocli"
+version = "0.1.0"
+authors = ["Daniel Mueller <deso@posteo.net>"]
+license = "GPL-3.0+"
+homepage = "https://github.com/d-e-s-o/nitrocli"
+repository = "https://github.com/d-e-s-o/nitrocli.git"
+readme = "README.md"
+keywords = ["hid", "nitrokey", "nitrokey-storage", "usb", "cli"]
+description = """
+A command line tool for interacting with the Nitrokey Storage device.
+"""