aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-02-19 12:58:07 +0000
committerRobin Krahl <robin.krahl@ireas.org>2019-02-19 14:54:24 +0100
commit55d3369d9e7f68bb0c836c8143778b2918f01ba5 (patch)
tree06b1c6b9563423af40b3710e71970138e68f147d /Cargo.toml
parentffb3d8f11b232e811bebfe0c9b450a8a95a7b12b (diff)
downloadntw-55d3369d9e7f68bb0c836c8143778b2918f01ba5.tar.gz
ntw-55d3369d9e7f68bb0c836c8143778b2918f01ba5.tar.bz2
Use ssmarshal to generate the response data
Previously, we manually constructed the data to sent with a Get_Report response. This patch introduces the Response struct which can be serialized using ssmarshal. As Serialize is only implemented for arrays with a length up to 32, we have to use the serde-big-array crate for the data field. As the command ID might not be recognized by us, we use a raw u8 value instead of the CommandId enum.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a11296e..b5f2c65 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,6 +14,7 @@ cortex-m = "0.5.8"
cortex-m-rt = "0.6.7"
embedded-hal = "0.2.2"
panic-halt = "0.2.0"
+serde-big-array = "0.1.4"
stm32f103xx-usb = { git = "https://github.com/mvirkkunen/stm32f103xx-usb", rev = "57d23751367461bec5f39322727bdd65e5c2aa30" }
usb-device = { git = "https://github.com/mvirkkunen/usb-device", rev = "e58e30f3b9c9bf4aab00ea039d129b964a3fd2d3" }