aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2018-05-20 10:59:41 +0000
committerRobin Krahl <robin.krahl@ireas.org>2018-05-20 13:04:43 +0200
commitf424891511b79e2ec1fb8e1dcb407228da693316 (patch)
tree1d209d4904ece8b5add596c683a775995d436892 /Cargo.toml
parent85ce1e4d5090caec42293d4b1746bc815095c8a2 (diff)
downloadnitrokey-sys-rs-f424891511b79e2ec1fb8e1dcb407228da693316.tar.gz
nitrokey-sys-rs-f424891511b79e2ec1fb8e1dcb407228da693316.tar.bz2
Replace generated with static code
Use bindgen to generate the bindings statically instead of during build. Code generation is not necessary as NK_C_API.h does not contain any system-dependent definitions. Removing bindgen as a build dependency also drastically speeds up compilation.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 0 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 68739b4..4e6268c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,9 +10,3 @@ license = "LGPL-3.0"
links = "nitrokey"
build = "build.rs"
readme = "README.md"
-
-[dependencies]
-libc = "0.2"
-
-[build-dependencies]
-bindgen = "0.37.0"