aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2018-05-20 22:31:34 +0000
committerRobin Krahl <robin.krahl@ireas.org>2018-05-21 00:35:19 +0200
commit9eee4b2475d74cd94c9d72b2520d5568d4564fba (patch)
tree83d44c03edff5b480db40bbd2c2284d21f17b696 /Cargo.toml
parent7fe2032c464ad7a79963823793e94e2c62b770e6 (diff)
downloadnitrokey-sys-rs-9eee4b2475d74cd94c9d72b2520d5568d4564fba.tar.gz
nitrokey-sys-rs-9eee4b2475d74cd94c9d72b2520d5568d4564fba.tar.bz2
Build libnitrokey from source
This patch changes the build script to compile and link libnitrokey from the included source. Also, we have to link against hidapi-libusb as a libnitrokey requirement.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4e6268c..7c4453c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,3 +10,6 @@ license = "LGPL-3.0"
links = "nitrokey"
build = "build.rs"
readme = "README.md"
+
+[build-dependencies]
+cc = "1.0"