aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-01-17 03:49:13 +0000
committerRobin Krahl <robin.krahl@ireas.org>2019-01-20 21:08:26 +0000
commitc43b63b70ee32f9fa8e980d89eff5383931f5c39 (patch)
tree8db1e07e151579d53957f3657eb3e0cfe8dcc723 /Cargo.toml
parent94390aadc8a3997d379bf5e4c0bc00c2a9669a34 (diff)
downloadnitrokey-rs-c43b63b70ee32f9fa8e980d89eff5383931f5c39.tar.gz
nitrokey-rs-c43b63b70ee32f9fa8e980d89eff5383931f5c39.tar.bz2
Add assert_cmd_err and assert_ok macros to tests
These macros allow easier comparisions using the new error type. This patch fixes all tests and updates nitrokey-test to 0.2.0 so that it integrates with the new error structure. Some tests may still fail until CommunicationError::NotConnected is actually returned.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 99ddd0c..cfe1579 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,4 +19,4 @@ rand_core = {version = "0.3", default-features = false}
rand_os = {version = "0.1"}
[dev-dependencies]
-nitrokey-test = {version = "0.1"}
+nitrokey-test = {version = "0.2"}