aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-07-09 10:51:55 +0000
committerRobin Krahl <robin.krahl@ireas.org>2019-07-09 12:55:30 +0200
commit4dc5b7e73ef348f18b4d2b032dc9a27059f4c47f (patch)
treef85556882dce88b47993844268961e42349e0be5 /Cargo.toml
parent5e8f0fbaf6df0cb919e4b02401cc21d5280bf09c (diff)
downloadnitrokey-rs-4dc5b7e73ef348f18b4d2b032dc9a27059f4c47f.tar.gz
nitrokey-rs-4dc5b7e73ef348f18b4d2b032dc9a27059f4c47f.tar.bz2
Update nitrokey-test development version
This patch updates the nitrokey-test dependency to a new development version that uses force_take instead of take to get a Manager instance. If a test fails, the thread panics, leading to a poisoned cache – yet this should not affect the other test cases. Therefore we want to ignore the poisoned caches.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e55f878..2106fd9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,5 +24,5 @@ rand_core = {version = "0.3", default-features = false, features = ["std"] }
rand_os = {version = "0.1"}
[dev-dependencies]
-nitrokey-test = {git = "https://github.com/robinkrahl/nitrokey-test", rev = "fdbe036720cf73dbb989e3a25611fa5cca4a513e"}
+nitrokey-test = {git = "https://github.com/robinkrahl/nitrokey-test", rev = "0550de7c50f9220a05c589a7c3d5c8185cc80344"}
nitrokey-test-state = "0.1.0"