summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..e096d97
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,21 @@
+[package]
+name = "nitrokey-hid"
+version = "0.1.0"
+authors = ["Robin Krahl <robin.krahl@ireas.org>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+serde-big-array = "0.3"
+ssmarshal = "1"
+static_assertions = "1"
+
+[dependencies.hidapi]
+version = "1.2.5"
+default-features = false
+features = ["linux-shared-libusb"]
+
+[dependencies.serde]
+version = "1"
+features = ["derive"]