aboutsummaryrefslogtreecommitdiff
path: root/unicode-width/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'unicode-width/Cargo.toml')
-rw-r--r--unicode-width/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/unicode-width/Cargo.toml b/unicode-width/Cargo.toml
new file mode 100644
index 0000000..35228f2
--- /dev/null
+++ b/unicode-width/Cargo.toml
@@ -0,0 +1,29 @@
+[package]
+
+name = "unicode-width"
+version = "0.1.7"
+authors = ["kwantam <kwantam@gmail.com>", "Manish Goregaokar <manishsmail@gmail.com>"]
+
+homepage = "https://github.com/unicode-rs/unicode-width"
+repository = "https://github.com/unicode-rs/unicode-width"
+documentation = "https://unicode-rs.github.io/unicode-width"
+license = "MIT/Apache-2.0"
+keywords = ["text", "width", "unicode"]
+readme = "README.md"
+description = """
+Determine displayed width of `char` and `str` types
+according to Unicode Standard Annex #11 rules.
+"""
+
+exclude = [ "target/*", "Cargo.lock" ]
+
+[dependencies]
+std = { version = "1.0", package = "rustc-std-workspace-std", optional = true }
+core = { version = "1.0", package = "rustc-std-workspace-core", optional = true }
+compiler_builtins = { version = "0.1", optional = true }
+
+[features]
+default = []
+no_std = []
+bench = []
+rustc-dep-of-std = ['std', 'core', 'compiler_builtins']