aboutsummaryrefslogtreecommitdiff
path: root/syn/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'syn/Cargo.toml')
-rw-r--r--syn/Cargo.toml72
1 files changed, 0 insertions, 72 deletions
diff --git a/syn/Cargo.toml b/syn/Cargo.toml
deleted file mode 100644
index 11ad921..0000000
--- a/syn/Cargo.toml
+++ /dev/null
@@ -1,72 +0,0 @@
-[package]
-name = "syn"
-version = "1.0.12" # don't forget to update html_root_url and syn.json
-authors = ["David Tolnay <dtolnay@gmail.com>"]
-license = "MIT OR Apache-2.0"
-description = "Parser for Rust source code"
-repository = "https://github.com/dtolnay/syn"
-documentation = "https://docs.rs/syn"
-categories = ["development-tools::procedural-macro-helpers"]
-readme = "README.md"
-include = [
- "/benches/**",
- "/build.rs",
- "/Cargo.toml",
- "/LICENSE-APACHE",
- "/LICENSE-MIT",
- "/README.md",
- "/src/**",
- "/tests/**",
-]
-edition = "2018"
-
-[features]
-default = ["derive", "parsing", "printing", "clone-impls", "proc-macro"]
-derive = []
-full = []
-parsing = []
-printing = ["quote"]
-visit = []
-visit-mut = []
-fold = []
-clone-impls = []
-extra-traits = []
-proc-macro = ["proc-macro2/proc-macro", "quote/proc-macro"]
-
-[dependencies]
-proc-macro2 = { version = "1.0.7", default-features = false }
-quote = { version = "1.0", optional = true, default-features = false }
-unicode-xid = "0.2"
-
-[dev-dependencies]
-anyhow = "1.0"
-flate2 = "1.0"
-insta = "0.12"
-rayon = "1.0"
-ref-cast = "1.0"
-regex = "1.0"
-reqwest = { version = "0.10", features = ["blocking"] }
-tar = "0.4"
-termcolor = "1.0"
-walkdir = "2.1"
-
-[[bench]]
-name = "rust"
-harness = false
-required-features = ["full", "parsing"]
-
-[[bench]]
-name = "file"
-required-features = ["full", "parsing"]
-
-[package.metadata.docs.rs]
-all-features = true
-
-[package.metadata.playground]
-all-features = true
-
-[badges]
-travis-ci = { repository = "dtolnay/syn" }
-
-[workspace]
-members = ["dev", "json"]