aboutsummaryrefslogtreecommitdiff
path: root/structopt/structopt-derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'structopt/structopt-derive/Cargo.toml')
-rw-r--r--structopt/structopt-derive/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/structopt/structopt-derive/Cargo.toml b/structopt/structopt-derive/Cargo.toml
new file mode 100644
index 0000000..ad547af
--- /dev/null
+++ b/structopt/structopt-derive/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "structopt-derive"
+version = "0.4.0"
+edition = "2018"
+authors = ["Guillaume Pinot <texitoi@texitoi.eu>"]
+description = "Parse command line argument by defining a struct, derive crate."
+documentation = "https://docs.rs/structopt-derive"
+repository = "https://github.com/TeXitoi/structopt"
+keywords = ["clap", "cli", "derive", "docopt"]
+categories = ["command-line-interface"]
+license = "Apache-2.0/MIT"
+
+[badges]
+travis-ci = { repository = "TeXitoi/structopt" }
+
+[dependencies]
+syn = { version = "1", features = ["full"] }
+quote = "1"
+proc-macro2 = "1"
+heck = "0.3.0"
+proc-macro-error = "0.4.3"
+
+[features]
+paw = []
+
+[lib]
+proc-macro = true