aboutsummaryrefslogtreecommitdiff
path: root/rand/rand_core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rand/rand_core/Cargo.toml')
-rw-r--r--rand/rand_core/Cargo.toml28
1 files changed, 0 insertions, 28 deletions
diff --git a/rand/rand_core/Cargo.toml b/rand/rand_core/Cargo.toml
deleted file mode 100644
index e52af5f..0000000
--- a/rand/rand_core/Cargo.toml
+++ /dev/null
@@ -1,28 +0,0 @@
-[package]
-name = "rand_core"
-version = "0.5.1"
-authors = ["The Rand Project Developers", "The Rust Project Developers"]
-license = "MIT OR Apache-2.0"
-readme = "README.md"
-repository = "https://github.com/rust-random/rand"
-documentation = "https://rust-random.github.io/rand/rand_core/"
-homepage = "https://crates.io/crates/rand_core"
-description = """
-Core random number generator traits and tools for implementation.
-"""
-keywords = ["random", "rng"]
-categories = ["algorithms", "no-std"]
-edition = "2018"
-
-[badges]
-travis-ci = { repository = "rust-random/rand" }
-appveyor = { repository = "rust-random/rand" }
-
-[features]
-std = ["alloc", "getrandom", "getrandom/std"] # use std library; should be default but for above bug
-alloc = [] # enables Vec and Box support without std
-serde1 = ["serde"] # enables serde for BlockRng wrapper
-
-[dependencies]
-serde = { version = "1", features = ["derive"], optional = true }
-getrandom = { version = "0.1", optional = true }