aboutsummaryrefslogtreecommitdiff
path: root/rand/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rand/Cargo.toml')
-rw-r--r--rand/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/rand/Cargo.toml b/rand/Cargo.toml
new file mode 100644
index 0000000..c21f53e
--- /dev/null
+++ b/rand/Cargo.toml
@@ -0,0 +1,35 @@
+[package]
+name = "rand"
+version = "0.4.3"
+authors = ["The Rust Project Developers"]
+license = "MIT/Apache-2.0"
+readme = "README.md"
+repository = "https://github.com/rust-lang-nursery/rand"
+documentation = "https://docs.rs/rand"
+homepage = "https://github.com/rust-lang-nursery/rand"
+description = """
+Random number generators and other randomness functionality.
+"""
+keywords = ["random", "rng"]
+categories = ["algorithms"]
+
+[features]
+default = ["std"]
+nightly = ["i128_support"] # enables all features requiring nightly rust
+
+std = ["libc"] # default feature; without this rand uses libcore
+alloc = [] # enables Vec and Box support without std
+
+i128_support = [] # enables i128 and u128 support
+
+[target.'cfg(unix)'.dependencies]
+libc = { version = "0.2", optional = true }
+
+[target.'cfg(windows)'.dependencies]
+winapi = { version = "0.3", features = ["minwindef", "ntsecapi", "profileapi", "winnt"] }
+
+[workspace]
+members = ["rand-derive"]
+
+[target.'cfg(target_os = "fuchsia")'.dependencies]
+fuchsia-zircon = "0.3.2"