aboutsummaryrefslogtreecommitdiff
path: root/proc-macro2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'proc-macro2/Cargo.toml')
-rw-r--r--proc-macro2/Cargo.toml57
1 files changed, 57 insertions, 0 deletions
diff --git a/proc-macro2/Cargo.toml b/proc-macro2/Cargo.toml
new file mode 100644
index 0000000..a7d0865
--- /dev/null
+++ b/proc-macro2/Cargo.toml
@@ -0,0 +1,57 @@
+[package]
+name = "proc-macro2"
+version = "1.0.7" # remember to update html_root_url
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+license = "MIT OR Apache-2.0"
+readme = "README.md"
+keywords = ["macros"]
+repository = "https://github.com/alexcrichton/proc-macro2"
+homepage = "https://github.com/alexcrichton/proc-macro2"
+documentation = "https://docs.rs/proc-macro2"
+edition = "2018"
+description = """
+A stable implementation of the upcoming new `proc_macro` API. Comes with an
+option, off by default, to also reimplement itself in terms of the upstream
+unstable API.
+"""
+
+[package.metadata.docs.rs]
+rustc-args = ["--cfg", "procmacro2_semver_exempt"]
+rustdoc-args = ["--cfg", "procmacro2_semver_exempt"]
+
+[dependencies]
+unicode-xid = "0.2"
+
+[dev-dependencies]
+quote = { version = "1.0", default_features = false }
+
+[features]
+proc-macro = []
+default = ["proc-macro"]
+
+# Expose methods Span::start and Span::end which give the line/column location
+# of a token.
+span-locations = []
+
+# This feature no longer means anything.
+nightly = []
+
+[badges]
+travis-ci = { repository = "alexcrichton/proc-macro2" }
+
+[workspace]
+members = ["benches/bench-libproc-macro"]
+
+[patch.crates-io]
+# Our doc tests depend on quote which depends on proc-macro2. Without this line,
+# the proc-macro2 dependency of quote would be the released version of
+# proc-macro2. Quote would implement its traits for types from that proc-macro2,
+# meaning impls would be missing when tested against types from the local
+# proc-macro2.
+#
+# Travis builds that are in progress at the time that you publish may spuriously
+# fail. This is because they'll be building a local proc-macro2 which carries
+# the second-most-recent version number, pulling in quote which resolves to a
+# dependency on the just-published most recent version number. Thus the patch
+# will fail to apply because the version numbers are different.
+proc-macro2 = { path = "." }