aboutsummaryrefslogtreecommitdiff
path: root/nitrokey/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'nitrokey/Cargo.toml')
-rw-r--r--nitrokey/Cargo.toml15
1 files changed, 7 insertions, 8 deletions
diff --git a/nitrokey/Cargo.toml b/nitrokey/Cargo.toml
index 238cc02..084bcea 100644
--- a/nitrokey/Cargo.toml
+++ b/nitrokey/Cargo.toml
@@ -1,6 +1,9 @@
+# Copyright (C) 2019 Robin Krahl <robin.krahl@ireas.org>
+# SPDX-License-Identifier: MIT
+
[package]
name = "nitrokey"
-version = "0.3.5"
+version = "0.4.0-alpha.0"
authors = ["Robin Krahl <robin.krahl@ireas.org>"]
edition = "2018"
homepage = "https://code.ireas.org/nitrokey-rs/"
@@ -12,15 +15,11 @@ categories = ["api-bindings"]
readme = "README.md"
license = "MIT"
-[features]
-test-pro = []
-test-storage = []
-
[dependencies]
libc = "0.2"
-nitrokey-sys = "~3.4"
-rand_core = {version = "0.3", default-features = false}
+nitrokey-sys = "3.4"
+rand_core = {version = "0.3", default-features = false, features = ["std"] }
rand_os = {version = "0.1"}
[dev-dependencies]
-nitrokey-test = {version = "0.1"}
+nitrokey-test = {version = "0.2"}