aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml12
1 files changed, 7 insertions, 5 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index b85acef..1d27ee5 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -20,6 +20,7 @@
[package]
name = "nitrocli"
version = "0.1.2"
+edition = "2018"
authors = ["Daniel Mueller <deso@posteo.net>"]
license = "GPL-3.0+"
homepage = "https://github.com/d-e-s-o/nitrocli"
@@ -34,10 +35,6 @@ A command line tool for interacting with the Nitrokey Storage device.
version = "1.0"
path = "../cc"
-[dependencies.hid]
-version = "0.4"
-path = "../hid"
-
[dependencies.hidapi-sys]
version = "0.1"
path = "../hidapi-sys"
@@ -46,13 +43,18 @@ path = "../hidapi-sys"
version = "0.2"
path = "../libc"
+[dependencies.libhid]
+version = "0.4"
+path = "../hid"
+package = "hid"
+
[dependencies.pkg-config]
version = "0.3"
path = "../pkg-config"
[replace]
"cc:1.0.25" = { path = "../cc" }
-"hid:0.4.1" = { path = "../hid" }
"hidapi-sys:0.1.4" = { path = "../hidapi-sys" }
"libc:0.2.45" = { path = "../libc" }
+"libhid:0.4.1" = { path = "../hid" }
"pkg-config:0.3.14" = { path = "../pkg-config" }