aboutsummaryrefslogtreecommitdiff
path: root/libc/libc-test/generate-files/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'libc/libc-test/generate-files/Cargo.toml')
-rw-r--r--libc/libc-test/generate-files/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/libc/libc-test/generate-files/Cargo.toml b/libc/libc-test/generate-files/Cargo.toml
new file mode 100644
index 0000000..8c19856
--- /dev/null
+++ b/libc/libc-test/generate-files/Cargo.toml
@@ -0,0 +1,16 @@
+# Cargo.toml which is used to just generate the all.{c,rs} files used to test
+# some platforms. These files are then combined with the overlay files commented
+# in the above directory as well to assemble a libc-test project which will
+# compile/run all tests.
+
+[package]
+name = "generate-files"
+version = "0.1.0"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+
+[[bin]]
+name = "generate-files"
+path = "../build.rs"
+
+[dependencies]
+ctest = "0.1"