aboutsummaryrefslogtreecommitdiff
path: root/libc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'libc/Cargo.toml')
-rw-r--r--libc/Cargo.toml17
1 files changed, 12 insertions, 5 deletions
diff --git a/libc/Cargo.toml b/libc/Cargo.toml
index c9be832..8d8272e 100644
--- a/libc/Cargo.toml
+++ b/libc/Cargo.toml
@@ -1,25 +1,32 @@
[package]
-
name = "libc"
-version = "0.2.36"
+version = "0.2.45"
authors = ["The Rust Project Developers"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
readme = "README.md"
repository = "https://github.com/rust-lang/libc"
homepage = "https://github.com/rust-lang/libc"
documentation = "http://doc.rust-lang.org/libc"
+keywords = ["libc", "ffi", "bindings", "operating", "system" ]
+categories = ["external-ffi-bindings", "no-std", "os"]
+build = "build.rs"
+exclude = ["/ci/*", "/.travis.yml", "/appveyor.yml"]
description = """
-A library for types and bindings to native C functions often found in libc or
-other common platform libraries.
+Raw FFI bindings to platform libraries like libc.
"""
[badges]
travis-ci = { repository = "rust-lang/libc" }
appveyor = { repository = "rust-lang/libc", project_name = "rust-lang-libs/libc" }
+[dependencies]
+rustc-std-workspace-core = { version = "1.0.0", optional = true }
+
[features]
default = ["use_std"]
use_std = []
+align = []
+rustc-dep-of-std = ['align', 'rustc-std-workspace-core']
[workspace]
members = ["libc-test"]