aboutsummaryrefslogtreecommitdiff
path: root/bitflags/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'bitflags/Cargo.toml')
-rw-r--r--bitflags/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/bitflags/Cargo.toml b/bitflags/Cargo.toml
new file mode 100644
index 0000000..afbe066
--- /dev/null
+++ b/bitflags/Cargo.toml
@@ -0,0 +1,37 @@
+[package]
+
+name = "bitflags"
+# NB: When modifying, also modify:
+# 1. html_root_url in lib.rs
+# 2. number in readme (for breaking changes)
+version = "1.2.1"
+authors = ["The Rust Project Developers"]
+license = "MIT/Apache-2.0"
+keywords = ["bit", "bitmask", "bitflags", "flags"]
+readme = "README.md"
+repository = "https://github.com/bitflags/bitflags"
+homepage = "https://github.com/bitflags/bitflags"
+documentation = "https://docs.rs/bitflags"
+categories = ["no-std"]
+description = """
+A macro to generate structures which behave like bitflags.
+"""
+exclude = [
+ ".travis.yml",
+ "appveyor.yml",
+ "bors.toml"
+]
+build = "build.rs"
+
+[badges]
+travis-ci = { repository = "bitflags/bitflags" }
+
+[features]
+default = []
+example_generated = []
+
+[package.metadata.docs.rs]
+features = [ "example_generated" ]
+
+[workspace]
+members = ["test_suite"]