aboutsummaryrefslogtreecommitdiff
path: root/rand/tests/wasm_bindgen/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2020-01-02 08:32:06 -0800
committerDaniel Mueller <deso@posteo.net>2020-01-02 08:32:06 -0800
commitfd091b04316db9dc5fafadbd6bdbe60b127408a9 (patch)
treef202270f7ae5cedc513be03833a26148d9b5e219 /rand/tests/wasm_bindgen/Cargo.toml
parent8161cdb26f98e65b39c603ddf7a614cc87c77a1c (diff)
downloadnitrocli-fd091b04316db9dc5fafadbd6bdbe60b127408a9.tar.gz
nitrocli-fd091b04316db9dc5fafadbd6bdbe60b127408a9.tar.bz2
Update nitrokey crate to 0.4.0
This change finally updates the version of the nitrokey crate that we consume to 0.4.0. Along with that we update rand_core, one of its dependencies, to 0.5.1. Further more we add cfg-if in version 0.1.10 and getrandom in version 0.1.13, both of which are now new (non-development) dependencies. Import subrepo nitrokey/:nitrokey at e81057037e9b4f370b64c0a030a725bc6bdfb870 Import subrepo cfg-if/:cfg-if at 4484a6faf816ff8058088ad857b0c6bb2f4b02b2 Import subrepo getrandom/:getrandom at d661aa7e1b8cc80b47dabe3d2135b3b47d2858af Import subrepo rand/:rand at d877ed528248b52d947e0484364a4e1ae59ca502
Diffstat (limited to 'rand/tests/wasm_bindgen/Cargo.toml')
-rw-r--r--rand/tests/wasm_bindgen/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/rand/tests/wasm_bindgen/Cargo.toml b/rand/tests/wasm_bindgen/Cargo.toml
new file mode 100644
index 0000000..e83c174
--- /dev/null
+++ b/rand/tests/wasm_bindgen/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "rand_wasm_bindgen_test"
+description = "Minimal crate to test that rand can be build for web assembly target"
+version = "0.1.0"
+authors = ["The Rand Project Developers"]
+publish = false
+license = "MIT OR Apache-2.0"
+edition = "2018"
+
+[lib]
+crate-type = ["cdylib"]
+
+[dependencies]
+rand = { path = "../..", features = ["wasm-bindgen"] }
+wasm-bindgen = "0.2"
+wasm-bindgen-test = "0.2"