aboutsummaryrefslogtreecommitdiff
path: root/rand/rand_distr/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2020-04-04 14:39:19 -0700
committerDaniel Mueller <deso@posteo.net>2020-04-04 14:39:19 -0700
commitd0d9683df8398696147e7ee1fcffb2e4e957008c (patch)
tree4baa76712a76f4d072ee3936c07956580b230820 /rand/rand_distr/Cargo.toml
parent203e691f46d591a2cc8acdfd850fa9f5b0fb8a98 (diff)
downloadnitrocli-d0d9683df8398696147e7ee1fcffb2e4e957008c.tar.gz
nitrocli-d0d9683df8398696147e7ee1fcffb2e4e957008c.tar.bz2
Remove vendored dependencies
While it appears that by now we actually can get successful builds without Cargo insisting on Internet access by virtue of using the --frozen flag, maintaining vendored dependencies is somewhat of a pain point. This state will also get worse with upcoming changes that replace argparse in favor of structopt and pull in a slew of new dependencies by doing so. Then there is also the repository structure aspect, which is non-standard due to the way we vendor dependencies and a potential source of confusion. In order to fix these problems, this change removes all the vendored dependencies we have. Delete subrepo argparse/:argparse Delete subrepo base32/:base32 Delete subrepo cc/:cc Delete subrepo cfg-if/:cfg-if Delete subrepo getrandom/:getrandom Delete subrepo lazy-static/:lazy-static Delete subrepo libc/:libc Delete subrepo nitrokey-sys/:nitrokey-sys Delete subrepo nitrokey/:nitrokey Delete subrepo rand/:rand
Diffstat (limited to 'rand/rand_distr/Cargo.toml')
-rw-r--r--rand/rand_distr/Cargo.toml27
1 files changed, 0 insertions, 27 deletions
diff --git a/rand/rand_distr/Cargo.toml b/rand/rand_distr/Cargo.toml
deleted file mode 100644
index 315a5b0..0000000
--- a/rand/rand_distr/Cargo.toml
+++ /dev/null
@@ -1,27 +0,0 @@
-[package]
-name = "rand_distr"
-version = "0.2.1"
-authors = ["The Rand Project Developers"]
-license = "MIT OR Apache-2.0"
-readme = "README.md"
-repository = "https://github.com/rust-random/rand"
-documentation = "https://rust-random.github.io/rand/rand_distr/"
-homepage = "https://crates.io/crates/rand_distr"
-description = """
-Sampling from random number distributions
-"""
-keywords = ["random", "rng", "distribution", "probability"]
-categories = ["algorithms"]
-edition = "2018"
-
-[badges]
-travis-ci = { repository = "rust-random/rand" }
-appveyor = { repository = "rust-random/rand" }
-
-[dependencies]
-rand = { path = "..", version = "0.7" }
-
-[dev-dependencies]
-rand_pcg = { version = "0.2", path = "../rand_pcg" }
-# Histogram implementation for testing uniformity
-average = "0.9.2"