aboutsummaryrefslogtreecommitdiff
path: root/nitrokey/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2020-04-04 14:39:19 -0700
committerDaniel Mueller <deso@posteo.net>2020-04-04 14:39:19 -0700
commitd0d9683df8398696147e7ee1fcffb2e4e957008c (patch)
tree4baa76712a76f4d072ee3936c07956580b230820 /nitrokey/Cargo.toml
parent203e691f46d591a2cc8acdfd850fa9f5b0fb8a98 (diff)
downloadnitrocli-d0d9683df8398696147e7ee1fcffb2e4e957008c.tar.gz
nitrocli-d0d9683df8398696147e7ee1fcffb2e4e957008c.tar.bz2
Remove vendored dependencies
While it appears that by now we actually can get successful builds without Cargo insisting on Internet access by virtue of using the --frozen flag, maintaining vendored dependencies is somewhat of a pain point. This state will also get worse with upcoming changes that replace argparse in favor of structopt and pull in a slew of new dependencies by doing so. Then there is also the repository structure aspect, which is non-standard due to the way we vendor dependencies and a potential source of confusion. In order to fix these problems, this change removes all the vendored dependencies we have. Delete subrepo argparse/:argparse Delete subrepo base32/:base32 Delete subrepo cc/:cc Delete subrepo cfg-if/:cfg-if Delete subrepo getrandom/:getrandom Delete subrepo lazy-static/:lazy-static Delete subrepo libc/:libc Delete subrepo nitrokey-sys/:nitrokey-sys Delete subrepo nitrokey/:nitrokey Delete subrepo rand/:rand
Diffstat (limited to 'nitrokey/Cargo.toml')
-rw-r--r--nitrokey/Cargo.toml27
1 files changed, 0 insertions, 27 deletions
diff --git a/nitrokey/Cargo.toml b/nitrokey/Cargo.toml
deleted file mode 100644
index b57591b..0000000
--- a/nitrokey/Cargo.toml
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright (C) 2019-2020 Robin Krahl <robin.krahl@ireas.org>
-# SPDX-License-Identifier: CC0-1.0
-
-[package]
-name = "nitrokey"
-version = "0.4.0"
-authors = ["Robin Krahl <robin.krahl@ireas.org>"]
-edition = "2018"
-homepage = "https://code.ireas.org/nitrokey-rs/"
-repository = "https://git.ireas.org/nitrokey-rs/"
-documentation = "https://docs.rs/nitrokey"
-description = "Bindings to libnitrokey for communication with Nitrokey devices"
-keywords = ["nitrokey", "otp"]
-categories = ["api-bindings"]
-readme = "README.md"
-license = "MIT"
-exclude = [".builds/*"]
-
-[dependencies]
-lazy_static = "1.2"
-libc = "0.2"
-nitrokey-sys = "3.5"
-rand_core = {version = "0.5.1", features = ["getrandom"] }
-
-[dev-dependencies]
-nitrokey-test = "0.3"
-nitrokey-test-state = "0.1"