aboutsummaryrefslogtreecommitdiff
path: root/nitrokey/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <me@robin-krahl.de>2018-12-11 23:50:45 +0100
committerDaniel Mueller <deso@posteo.net>2018-12-17 07:52:13 -0800
commit986ad2f782cf944990e4eda8bf88ea1821233302 (patch)
tree1717075a4eb11861c32e5c45d01e47360fb1264d /nitrokey/Cargo.toml
parente97c287c01cf22a1b582a7da9b309b58f3935d0e (diff)
downloadnitrocli-986ad2f782cf944990e4eda8bf88ea1821233302.tar.gz
nitrocli-986ad2f782cf944990e4eda8bf88ea1821233302.tar.bz2
Add nitrokey as a dependency to nitrocli
The nitrokey crate provides a simple interface to the Nitrokey Storage and the Nitrokey Pro based on the libnitrokey library developed by Nitrokey UG. The low-level bindings to this library are available in the nitrokey-sys crate. This patch adds version v0.2.1 of the nitrokey crate as a dependency for nitrocli. It includes the indirect dependencies nitrokey-sys (version 3.4.1) and rand (version 0.4.3). Import subrepo nitrokey/:nitrokey at 2eccc96ceec2282b868891befe9cda7f941fbe7b Import subrepo nitrokey-sys/:nitrokey-sys at f1a11ebf72610fb9cf80ac7f9f147b4ba1a5336f Import subrepo rand/:rand at d7d5da49daf7ceb3e5940072940d495cced3a1b3
Diffstat (limited to 'nitrokey/Cargo.toml')
-rw-r--r--nitrokey/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/nitrokey/Cargo.toml b/nitrokey/Cargo.toml
new file mode 100644
index 0000000..dad751b
--- /dev/null
+++ b/nitrokey/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "nitrokey"
+version = "0.2.1"
+authors = ["Robin Krahl <robin.krahl@ireas.org>"]
+homepage = "https://code.ireas.org/nitrokey-rs/"
+repository = "https://git.ireas.org/nitrokey-rs/"
+documentation = "https://docs.rs/nitrokey"
+description = "Bindings to libnitrokey for communication with Nitrokey devices"
+keywords = ["nitrokey", "otp"]
+categories = ["api-bindings"]
+readme = "README.md"
+license = "MIT"
+
+[features]
+test-no-device = []
+test-pro = []
+test-storage = []
+
+[dependencies]
+libc = "0.2"
+nitrokey-sys = "3.4.1"
+rand = "0.4"