aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2018-12-10 20:56:24 -0800
committerDaniel Mueller <deso@posteo.net>2018-12-10 20:56:24 -0800
commitdf88d39cd9c7b254057ee80dad5367313f2bb87f (patch)
treea7b34c6a87efd3a6d3be6f2c5d0fbd8a6148284d /nitrocli/Cargo.toml
parent70628261ebf7ed9118a2b00828c5b9107754d07d (diff)
downloadnitrocli-df88d39cd9c7b254057ee80dad5367313f2bb87f.tar.gz
nitrocli-df88d39cd9c7b254057ee80dad5367313f2bb87f.tar.bz2
Specify version requirements in a less strict manner
We try to adhere to the Semantic Versioning convention and expect dependent crates to do the same. So far we have been fairly strict in terms of the specific versions we consume, specifying the full version triple (x.y.z). This change loosens that stance by only specifying the minor version requirement of dependencies, not the patch level (i.e., x.y).
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index c102734..741bf3c 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -31,23 +31,23 @@ A command line tool for interacting with the Nitrokey Storage device.
"""
[dependencies.cc]
-version = "1.0.4"
+version = "1.0"
path = "../cc"
[dependencies.hid]
-version = "0.4.1"
+version = "0.4"
path = "../hid"
[dependencies.hidapi-sys]
-version = "0.1.4"
+version = "0.1"
path = "../hidapi-sys"
[dependencies.libc]
-version = "0.2.36"
+version = "0.2"
path = "../libc"
[dependencies.pkg-config]
-version = "0.3.9"
+version = "0.3"
path = "../pkg-config"
[replace]