aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-01-06 00:20:04 +0100
committerDaniel Mueller <deso@posteo.net>2019-01-13 18:37:08 -0800
commitcb5b22d0886a0a8c19cf1afeef55a8245357cf20 (patch)
treecfcc555186317bac4f4383a9380e0d6ef6d58459 /nitrocli/Cargo.toml
parent38e7e1d92ce4aea7840d78bcda6246bd61c423ac (diff)
downloadnitrocli-cb5b22d0886a0a8c19cf1afeef55a8245357cf20.tar.gz
nitrocli-cb5b22d0886a0a8c19cf1afeef55a8245357cf20.tar.bz2
Add the base32 crate in version 0.4.0 as a dependency
To parse OTP secrets in base32 representation, we need a new dependency: the base32 crate. Import subrepo base32/:base32 at a74cd9246fc0e08d6f5cfcb644bfdf76dd438613
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index 0fc6482..8440460 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -45,6 +45,10 @@ incremental = false
version = "0.2.2"
path = "../argparse"
+[dependencies.base32]
+version = "0.4.0"
+path = "../base32"
+
[dependencies.libc]
version = "0.2"
path = "../libc"
@@ -55,6 +59,7 @@ path = "../nitrokey"
[replace]
+"base32:0.4.0" = { path = "../base32" }
"cc:1.0.28" = { path = "../cc" }
"libc:0.2.45" = { path = "../libc" }
"nitrokey-sys:3.4.1" = { path = "../nitrokey-sys" }