aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2019-01-05 17:46:42 -0800
committerDaniel Mueller <deso@posteo.net>2019-01-05 17:46:42 -0800
commitba506bfa085064b9be3e262806d2f5f4ca522aee (patch)
tree65b2faf2fc9e5cb897928ba85aa3445974b74709 /nitrocli/Cargo.toml
parentb4516220b95743b485b9bcd8226285255be9c9c4 (diff)
downloadnitrocli-ba506bfa085064b9be3e262806d2f5f4ca522aee.tar.gz
nitrocli-ba506bfa085064b9be3e262806d2f5f4ca522aee.tar.bz2
Add first set of integration tests
This change introduces the first set of integration-style test for the application. Those tests may or may not connect to an actual Nitrokey device (depending on what they test). We use the nitrokey-test crate's test attribute macro to automatically dispatch tests to connected devices or skip them if a required device is not present. It also provides the means for automatically serializing tests.
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index 8440460..42b3ae9 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -57,6 +57,11 @@ path = "../libc"
version = "0.3"
path = "../nitrokey"
+[dev-dependencies.nitrokey-test]
+version = "0.1.1"
+
+[dev-dependencies.regex]
+version = "1"
[replace]
"base32:0.4.0" = { path = "../base32" }