aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2017-05-29 15:48:40 -0700
committerDaniel Mueller <deso@posteo.net>2017-05-29 15:48:40 -0700
commitac29709a644682c61a5a28d2a23f8887174fcc31 (patch)
treeca655f52ce768615eb288a507fb8ca8aa8a21d2a /nitrocli/Cargo.toml
parent684c4574c09a6f2cc5a208e4505e9306602b4abc (diff)
downloadnitrocli-ac29709a644682c61a5a28d2a23f8887174fcc31.tar.gz
nitrocli-ac29709a644682c61a5a28d2a23f8887174fcc31.tar.bz2
Explicitly mention versions for local dependencies
Although the version information for all the local dependencies can be inferred from various locations, cargo requires an explicit mentioning of the version of each dependency for the 'package' command to be successful. This change adds explicit versions.
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index a1b7730..d850552 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -31,18 +31,23 @@ A command line tool for interacting with the Nitrokey Storage device.
"""
[dependencies.gcc]
+version = "0.3.48"
path = "../gcc"
[dependencies.hid]
+version = "0.4.0"
path = "../hid"
[dependencies.hidapi-sys]
+version = "0.1.2"
path = "../hidapi-sys"
[dependencies.libc]
+version = "0.2.23"
path = "../libc"
[dependencies.pkg-config]
+version = "0.3.9"
path = "../pkg-config"
[replace]