aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <me@robin-krahl.de>2018-12-11 23:50:45 +0100
committerDaniel Mueller <deso@posteo.net>2018-12-17 07:52:13 -0800
commit986ad2f782cf944990e4eda8bf88ea1821233302 (patch)
tree1717075a4eb11861c32e5c45d01e47360fb1264d /nitrocli/Cargo.toml
parente97c287c01cf22a1b582a7da9b309b58f3935d0e (diff)
downloadnitrocli-986ad2f782cf944990e4eda8bf88ea1821233302.tar.gz
nitrocli-986ad2f782cf944990e4eda8bf88ea1821233302.tar.bz2
Add nitrokey as a dependency to nitrocli
The nitrokey crate provides a simple interface to the Nitrokey Storage and the Nitrokey Pro based on the libnitrokey library developed by Nitrokey UG. The low-level bindings to this library are available in the nitrokey-sys crate. This patch adds version v0.2.1 of the nitrokey crate as a dependency for nitrocli. It includes the indirect dependencies nitrokey-sys (version 3.4.1) and rand (version 0.4.3). Import subrepo nitrokey/:nitrokey at 2eccc96ceec2282b868891befe9cda7f941fbe7b Import subrepo nitrokey-sys/:nitrokey-sys at f1a11ebf72610fb9cf80ac7f9f147b4ba1a5336f Import subrepo rand/:rand at d7d5da49daf7ceb3e5940072940d495cced3a1b3
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index a3414c0..83e6888 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -49,6 +49,11 @@ version = "0.4"
path = "../hid"
package = "hid"
+[dependencies.libnitrokey]
+version = "0.2.1"
+path = "../nitrokey"
+package = "nitrokey"
+
[dependencies.pkg-config]
version = "0.3"
path = "../pkg-config"
@@ -58,4 +63,7 @@ path = "../pkg-config"
"hidapi-sys:0.1.4" = { path = "../hidapi-sys" }
"libc:0.2.45" = { path = "../libc" }
"libhid:0.4.1" = { path = "../hid" }
+"libnitrokey:0.2.1" = { path = "../nitrokey" }
+"nitrokey-sys:3.4.1" = { path = "../nitrokey-sys" }
"pkg-config:0.3.14" = { path = "../pkg-config" }
+"rand:0.4.3" = { path = "../rand" }