aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2019-01-06 09:02:10 -0800
committerDaniel Mueller <deso@posteo.net>2019-01-06 09:02:10 -0800
commit865f15edfdd7fca61b68da3c0aa3293dba630c81 (patch)
tree59ddb59e070f8afcf5b1c4fdd3c730c6430952f6 /nitrocli/Cargo.toml
parent2095641dd9d1245d7f7425e008f4bff8bfcd8a84 (diff)
downloadnitrocli-865f15edfdd7fca61b68da3c0aa3293dba630c81.tar.gz
nitrocli-865f15edfdd7fca61b68da3c0aa3293dba630c81.tar.bz2
Do not intermix path and replace attributes in Cargo.toml
With the first usage of the nitrokey crate we have used the dependency's path attribute to perform the replacement with a local version of the source code, while most other dependencies are replaced using the [replace] section. Because the [replace] section is more flexible (it allows for replacement of transitive dependencies), this change unifies all dependencies to use it.
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml5
1 files changed, 2 insertions, 3 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index ae27e63..279c6c9 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -43,7 +43,6 @@ incremental = false
[dependencies.argparse]
version = "0.2.2"
-path = "../argparse"
[dependencies.base32]
version = "0.4.0"
@@ -51,11 +50,9 @@ path = "../base32"
[dependencies.libc]
version = "0.2"
-path = "../libc"
[dependencies.nitrokey]
version = "0.3.1"
-path = "../nitrokey"
[dev-dependencies.nitrokey-test]
version = "0.1.1"
@@ -64,9 +61,11 @@ version = "0.1.1"
version = "1"
[replace]
+"argparse:0.2.2" = { path = "../argparse" }
"base32:0.4.0" = { path = "../base32" }
"cc:1.0.28" = { path = "../cc" }
"libc:0.2.45" = { path = "../libc" }
+"nitrokey:0.3.1" = { path = "../nitrokey" }
"nitrokey-sys:3.4.1" = { path = "../nitrokey-sys" }
"rand:0.6.1" = { path = "../rand" }
"rustc_version:0.2.3" = { path = "../rustc_version" }