aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorRobin Krahl <robin.krahl@ireas.org>2019-01-10 23:15:41 +0000
committerDaniel Mueller <deso@posteo.net>2019-01-26 22:04:29 -0800
commit77ff522ba2ebee17eb56f52921f127fba2fbd7fb (patch)
treef818d6b2441cb3c735e92bee5f63a377ec38a7eb /nitrocli/Cargo.toml
parentfbb307551de0d26e612d1b00f386ccf45d84b066 (diff)
downloadnitrocli-77ff522ba2ebee17eb56f52921f127fba2fbd7fb.tar.gz
nitrocli-77ff522ba2ebee17eb56f52921f127fba2fbd7fb.tar.bz2
Refactor get_device to use nitrokey::connect_model
nitrokey 0.3.1 introduced the connect_model function that connects to a specific model given by an enum variant and returns a DeviceWrapper. This new function allows us to remove the manual selection of a connection method from the get_device function. We only have to implement From<DeviceModel> for nitrokey::Model to be able to convert our model enum to nitrokey's model enum.
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index 0c567c7..ae27e63 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -54,7 +54,7 @@ version = "0.2"
path = "../libc"
[dependencies.nitrokey]
-version = "0.3"
+version = "0.3.1"
path = "../nitrokey"
[dev-dependencies.nitrokey-test]