aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2018-12-16 20:28:36 -0800
committerDaniel Mueller <deso@posteo.net>2018-12-16 20:28:36 -0800
commit6d0db4ef0d3c1cde9cc98606cbbb32977ece4218 (patch)
treef0a96ec200f2326d2cebb81e735b1f11ab1035d2 /nitrocli/Cargo.toml
parent5116ac035a5ea5994ffadb8a497531fd1f3f4f3b (diff)
downloadnitrocli-6d0db4ef0d3c1cde9cc98606cbbb32977ece4218.tar.gz
nitrocli-6d0db4ef0d3c1cde9cc98606cbbb32977ece4218.tar.bz2
Add gitlab-ci.yml configuration file
This change adds a configuration file for the Gitlab CI/CD pipeline to the repository. This file (directly or indirectly) controls the environment in which to build, what exactly to build, and ultimately would also be used to define what tests to run. With the pipeline in place the change also adds a badge indicating the status of the build on the project's front page. The following other CI services have been evaluated or tested and found to be insufficient for the needs at hand: - Travis CI: Does not support configuration in a directory other than the repository root - Cirrus CI: Has the same problem - Semaphore: Does not support Rust - Circle CI: Does not support Rust - Google Cloud Build: Pretty much strictly a paid service
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index 895043b..0c9f0f4 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -32,6 +32,9 @@ description = """
A command line tool for interacting with the Nitrokey Storage device.
"""
+[badges]
+gitlab = { repository = "d-e-s-o/nitrocli", branch = "devel" }
+
[dependencies.nitrokey]
version = "0.2.1"
path = "../nitrokey"