aboutsummaryrefslogtreecommitdiff
path: root/nitrocli/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Mueller <deso@posteo.net>2019-01-01 17:21:10 -0800
committerDaniel Mueller <deso@posteo.net>2019-01-01 17:21:10 -0800
commit696d9fb4164c2c92fa614030c18a4216e7bd4c13 (patch)
treec5e7f4966c1beebb7687e103de637828003b7581 /nitrocli/Cargo.toml
parenta98e417c3373a91fc12df8e483222f67dfac5335 (diff)
downloadnitrocli-696d9fb4164c2c92fa614030c18a4216e7bd4c13.tar.gz
nitrocli-696d9fb4164c2c92fa614030c18a4216e7bd4c13.tar.bz2
Bump version to 0.2.0
This change bumps the version of the crate to 0.2.0. The following notable changes have been made since 0.1.3: - Use the nitrokey crate for the 'open', 'close', and 'status' commands instead of directly communicating with the Nitrokey device - Added nitrokey version 0.2.1 as a direct dependency and nitrokey-sys version 3.4.1 as well as rand version 0.4.3 as indirect dependencies - Removed the hid, hidapi-sys and pkg-config dependencies - Added the 'otp' command for working with one-time passwords - Added the 'config' command for reading and writing the device configuration - Added the 'pin' command for managing PINs - Renamed the 'clear' command to 'pin clear' - Moved 'open' and 'close' commands as subcommands into newly introduced 'storage' command - Moved printing of storage related information from 'status' command into new 'storage status' subcommand - Made 'status' command work with Nitrokey Pro devices - Enabled CI pipeline comprising code style conformance checks, linting, and building of the project - Added badges indicating pipeline status, current crates.io published version of the crate, and minimum version of rustc required - Fixed wrong messages in the pinentry dialog that were caused by unescaped spaces in a string - Use the argparse crate to parse the command-line arguments - Added argparse dependency in version 0.2.2
Diffstat (limited to 'nitrocli/Cargo.toml')
-rw-r--r--nitrocli/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/nitrocli/Cargo.toml b/nitrocli/Cargo.toml
index 42a411f..ff3034a 100644
--- a/nitrocli/Cargo.toml
+++ b/nitrocli/Cargo.toml
@@ -1,7 +1,7 @@
# Cargo.toml
#/***************************************************************************
-# * Copyright (C) 2017-2018 Daniel Mueller (deso@posteo.net) *
+# * Copyright (C) 2017-2019 Daniel Mueller (deso@posteo.net) *
# * *
# * This program is free software: you can redistribute it and/or modify *
# * it under the terms of the GNU General Public License as published by *
@@ -19,7 +19,7 @@
[package]
name = "nitrocli"
-version = "0.1.3"
+version = "0.2.0"
edition = "2018"
authors = ["Daniel Mueller <deso@posteo.net>"]
license = "GPL-3.0+"